博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
hdu 1496 hdoj 1496
阅读量:4122 次
发布时间:2019-05-25

本文共 1324 字,大约阅读时间需要 4 分钟。

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2161    Accepted Submission(s): 839
Problem Description
Consider equations having the following form:
a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.
It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.
Determine how many solutions satisfy the given equation.
 
Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 
Output
For each test case, output a single line containing the number of the solutions.
 
Sample Input
1 2 3 -41 1 1 1
 
Sample Output
390880
 #include<stdio.h>
#include<memory.h>
int pin[101];
int hash[2000003];
main()
{
    int a,b,c,d,i,j,sum;
    for(i=1;i<=100;i++)
    {
        pin[i]=i*i;
    }
    while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
    {
        if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0))
        {
            printf("0\n");
            continue;
        }
        sum=0;
        memset(hash,0,sizeof(hash));
        for(i=1;i<=100;i++)
        {
            for(j=1;j<=100;j++)
            {
                hash[a*pin[i]+b*pin[j]+1000000]++;
            }
        }
        for(i=1;i<=100;i++)
        {
            for(j=1;j<=100;j++)
            {
                sum+=hash[-c*pin[i]-d*pin[j]+1000000];
            }
        }
        printf("%d\n",sum*16);
    }
}

转载地址:http://mttpi.baihongyu.com/

你可能感兴趣的文章
vue项目使用安装sass
查看>>
HTTP和HttpServletRequest 要点
查看>>
在osg场景中使用GLSL语言——一个例子
查看>>
关于无线PCB中 中50欧姆的特性阻抗的注意事项
查看>>
Spring的单例模式源码小窥
查看>>
后台服务的变慢排查思路(轻量级应用服务器中测试)
查看>>
MySQL中InnoDB事务的默认隔离级别测试
查看>>
微服务的注册与发现
查看>>
bash: service: command not found
查看>>
linux Crontab 使用 --定时任务
查看>>
shell编程----目录操作(文件夹)
查看>>
机器学习-----K近邻算法
查看>>
HBASE安装和简单测试
查看>>
关于程序员的59条搞笑但却真实无比的编程语录
查看>>
搞笑--一篇有趣的文章编译自一篇西班牙博客。有一位美丽的公主,被关押在一个城堡中最高的塔上,一条凶恶的巨龙看守着她,需要有一位勇士营救她…
查看>>
非常不错 Hadoop 的HDFS (Hadoop集群(第8期)_HDFS初探之旅)
查看>>
Tomcat启动错误,端口占用
查看>>
laravel 修改api返回默认的异常处理
查看>>
高德坐标转换百度坐标 javascript
查看>>
tp5封装通用的修改某列值
查看>>